EMD SD10 – DME Patched

(2 customer reviews)

Log in to Purchase $14.99

JointedRail content is currently supported ONLY in Trainz Railroad Simulator 2019 117009 to current TRS22 and plus versions. Items may require connection to the N3V download station for some dependencies.

Model and Textures by Amm4425

This item is for Trainz: A New Era SP4 or higher.

Last update: September 7, 2022

Description

2 reviews for EMD SD10 – DME Patched

  1. Grifferdude (verified owner)

    Patching Is Amazing!

  2. Alex (verified owner)

    Great Looking Locomotive ūüôā

Only logged in customers who have purchased this product may leave a review.

You may also like…