GE B40-8 – ATSF and BNSF Patch

(2 customer reviews)

Log in to Purchase $19.99

JointedRail content is currently supported ONLY in Trainz Railroad Simulator 2019 117009 to current TRS22 and plus versions. Items may require connection to the N3V download station for some dependencies.

Model and Textures by Amm4425

Includes as built (early) and late models and early/late BNSF patches with number specific weathering

This item is for Trainz: 2019 SP5 or higher

Last update: April 5, 2024

Description

 

2 reviews for GE B40-8 – ATSF and BNSF Patch

  1. gallipat5591 (verified owner)

    10/10 Fantastico

  2. Alex (verified owner)

    They dropped these out of nowhere, but oh boy am i glad they did. really looking forward to more liveries of these units going forward, awesome stuff!

Only logged in customers who have purchased this product may leave a review.